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1 Introduction

In many, if not most testing programs that employ equating, the new form
is equated to at least two previously equated forms, say k of them. In such
cases, the final conversion table is typically taken as some weighted average of
the k conversions, where each of the k conversions is based on some particular
equating method. (Kolen & Brennan, 2004, provide detailed descriptions of
numerous methods for equating forms of a test.) Typically, the results for
multiple methods are examined for each link, a particular method is chosen
for each link, and then the final conversion table is some weighted average
of the one particular user-selected method for each link. ESUM (Equating
SUMmary) is intended to facilitate these tasks. Note that ESUM does not
perform the equating for any particular method; computer programs available
on the CASMA website (www.education.uiowa.edu/casma) can be used to do so.
(See, in particular, Equating Recipes by Brennan, Wang, Kim & Seol, 2009.)
Rather, ESUM displays numerical and graphical results that can help a user
select a method for each link and ultimately choose the final conversion for the
new form.1

ESUM takes as input the conversion tables and related information for each
of the equating methods employed with each of the k links. Note that the
equating methods for the various links need not be the same. Indeed, even
the designs used for equating may differ by link, although this is rare (e.g.,
the random groups design could be used for one link and the common-item
nonequivalent groups design could be used for another link). In short, ESUM
has no information about how the conversion tables for each method and link
were generated.

The output for ESUM is of two types:

• equating results and plots for each link (one worksheet per link); and

• equating conversion tables and related plots for the “new” form based on
a weighted average (weights chosen by user) of the equating conversion
tables for the user-selected method for each link.

Letting the second type of output be called an “equating summary,” ESUM
permits the user to obtain as many equating summaries as desired. Specifically,
the user can obtain equating summaries for as many different sets of methods
(one per link) and weights (one per link) as desired.

ESUM is a set of Excel VBA (Visual Basic for Applications) macros. VBA
is the programming language used to automate procedures in Microsoft appli-
cations, including Excel. In this sense, VBA enables users to add their own
custom features to Microsoft applications. Using VBA, tasks in Excel can gen-
erally be performed more quickly. So, the user can think of ESUM as a computer
program that “sits on top” of Excel, which means that after ESUM is run, all

1The maximum number of links in ESUM is four; the maximum number of methods per
link in 50.
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the features and capabilities of Excel are available to the user to manipulate,
compute, or plot any of the ESUM results.

The ESUM VBA macros code and this ESUM manual are freely available
on www.education.uiowa.edu/casma, which is the website for the Center for
Advanced Studies in Measurement and Assessment (CASMA) at the University
of Iowa. Typical copyright rules apply. The VBA code is available under the
open-source license conditions discussed in Section 7.

Almost all of the major components of ESUM were originally coded using
Excel 2003, and ESUM will run under Excel 2003. ESUM will also run under
Excel 2007 and Excel 2010 in what is called “compatibility mode.” As far
as ESUM is concerned, the major difference between Excel 2003 and Excel
2007/2010 is that floating toolbars in Excel 2003 have been replaced by Add-
Ins in Excel 2007/2010. (See Section 6.2 for more details.) Section 6 discusses,
in considerable detail, a number of issues associated with differences between
these three versions of Excel as they relate to ESUM.

Importantly, in this manual, we generally follow the convention of discussing
issues from the perspective of Excel 2003. Then, at the end of certain sections,
relevant differences between Excel 2003 and Excel 2007/2010 are discussed.

In this manual, filenames are in typewriter style (e.g. filename), underlining
indicates a pop-up menu (e.g., File), and italics is used for menu items and
commands (e.g., Save). Occasionally, typewriter style is also used to identify a
variable name.

2 Running ESUM: The Basics

ESUM is in the format of an Excel workbook named ESUM.xls. After double-
clicking on ESUM.xls, Microsoft Excel is launched. Note that in order to run
ESUM, Excel macros must be enabled. (See section 6.1 for more information
about enabling macros and security.)

When ESUM.xls is launched, a Welcome Window appears with a brief in-
troduction, contact information, and disclaimers. At the bottom of the window
are four buttons:

• New : begin a new ESUM workbook (see also Section 4.1.1),

• Open: load an already created ESUM workbook (see also Sections 4.1.2
and 4.1.4),

• Continue: continue working on the present workbook, and

• Exit : closes ESUM.xls and removes the ESUM toolbar.

The functionality of the last three buttons is explained more fully in subsequent
sections. For now, we assume the user has just downloaded ESUM from the
CASMA website and wants to process the sample run. To do so, perform the
following steps.

2
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• Click New and note that the ESUM floating toolbar appears. The toolbar
is described in great detail later in section 4, which also discusses what to
do if the toolbar does not appear.

• Under the File menu, click Input Window. A blank Input Window ap-
pears. (Typically, the user would enter the required information in this
window.)

• At the bottom of the Input Window, click Load Example. This automat-
ically enters the required information for the sample run, which has two
links. This example is purely hypothetical data.

• At the bottom of the Input Window, click OK. This signals that all the
required information has been entered in the Input Window. When OK
is clicked, the Input Worksheet appears that summarizes the information
entered in the Input Window.

• In the ESUM toolbar, click Run Analysis. Worksheets are created for each
of the k links. Each worksheet includes conversion tables for all methods
for rounded and unrounded scale scores, comparisons of these conversion
tables with a user-specified baseline (e.g., conversion table for the old
form), moments of score distributions, and plots.

• In the ESUM toolbar, click Summary. A popup window appears in which
the user picks one method for each link, as well as a weight for each link.
(The weights must sum to 1.0.) For the first link (named “aaa”), sup-
pose the user picks “Tucker” with a weight of 0.5; and for the second
link (named “bbb”), suppose the user picks “L-obs” with a weight of 0.5.2

When OK is clicked a new worksheet is created named “Summary1” that
provides the new form conversion table averaged over links (unrounded
and rounded versions), along with various comparisons, moments, and
plots. Additional summary worksheets can be created in the same man-
ner, which allows the user to examine the effects on the final new-form
conversion of choices of different methods and/or weights.

2.1 Saving and Opening Workbooks

Once the user is through with an analysis, the user can exit Excel by choosing
the Exit command in the ESUM Welcome window on the ESUM toolbar, or
the Exit command under the File menu on the ESUM toolbar. Alternatively,
the user can save the workbook using the Save command under the File menu
on the ESUM toolbar. If the user chooses Save, a file-dialogue window appears
that allows the user to save the workbook with any name desired in any folder.
The default name is temp.xls, and the default location is the folder in which

2Each weight should begin with 0., and the weights must sum to 1. If a weight is a repeating
decimal (e.g., one-sixth), provide at least ten decimal digits (e.g., 0.1666666666).

3



Brennan and Chien ESUM Manual

ESUM.xls resides.3 It is particularly important to note that the Excel Save
command should not be used to save an ESUM Workbook.

Suppose the user saves the workbook as my-first-try.xls and exits Excel.
If the user then double-clicks on my-first-try.xls, the workbook will appear,
and all Excel functions can be used in that workbook. However, the ESUM
macros are NOT available, which means, for example, that a new summary
analysis cannot be performed. To make the ESUM macros available with a
saved workbook, the user can follow these steps:

• open ESUM.xls if it is not already open

• click New in the Welcome Window or in the File menu on the ESUM
toolbar

• click Open in the Welcome Window or in the File menu on the ESUM
toolbar

• from the file-selection dialog box, open my-first-try.xls

Another way to save a workbook and still have access to the ESUM macros
later is to do the following:

• from the File menu of the ESUM toolbar choose Exit

• a dialog box will appear asking if you want to save your work—choose Yes

Then, to use the original workbook with the ESUM macros enabled,

• open ESUM.xls

• click Continue in the Welcome Window

2.2 Using Excel 2007/2010

When using Excel 2007/2010, double-clicking ESUM.xls opens the Welcome
Window described above, but clicking New in the Welcome window does not
reveal the floating toolbar. The floating toolbar functionality is provided by the
Add-Ins tab in the Excel ribbon.4 When using Excel 2007/2010, after clicking
New in the ESUM Welcome Window, click the Add-Ins tab. Then, just below
the Excel ribbon, the following horizontal list of menu items will appear: ESUM,
File, Run Analysis, Summary, and Help. The last four menu items are discussed
in Section 4. Clicking the ESUM menu item in the ESUM.xls Add-Ins can be
used at any time to begin a new analysis.5 Throughout this manual the phrase
“ESUM.xls toolbar” should be understood in the sense of “ESUM.xls toolbar for
Excel 2003 or ESUM.xls Add-Ins for Excel 2007/2010.”

3Currently, sometimes when saving a file four error messages appear in succession. Click
“Yes” each time, and the file will be saved properly.

4For Excel 2010, if the Add-Ins tab is not in the ribbon, see Section 6.2.
5Usually it is advisable to save the current analysis before beginning a new one. To do so,

see Section 4.1.4.
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3 Input Files

For each link, there must be an input file that provides the equating conversion
tables for the various methods employed by the user, as well as some other
information. For the example, there are two links, and, hence, two files. They
are named scale1.txt and scale2.txt.

Let the number of methods for link j (j = 1, 2, . . . , k) be denoted mj . If
there are n possible raw scores (integers that may be positive, zero, or negative),
there must be n+ 1 records in the input file. The first record is a type of user-
defined header, described below. The remaining records contain the following
data in the indicated order:

1. raw score for new form

2. scale score for old form

3. frequency for new form

4. relative frequency for new form

5. scale score for first method

6. scale score for second method

· · ·

4 +mj . scale score of mj-th method

Strictly speaking, ESUM does not know what forms are involved in columns
2–4, and for columns 3 and 4 ESUM does not know what (sub)sample or
(sub)population generated the frequencies and relative frequencies. So, the user
has to exercise some appropriate judgment in generating the input files. Gen-
erally, the frequencies and relative frequencies should be the same for each link,
but this consistency is not enforced by ESUM.

The scale scores are usually unrounded scale scores.6 Each piece of data
should be separated by one or more tabs or spaces. Each record should end
with a carriage return, including the last record. Make sure that there are
no spaces and/or tabs at the beginning of any record. The records should be
ordered in terms of raw scores from low to high, or from high to low.7 The file
should be saved as a text-only file.

The first record provides the labels used by ESUM. If a label includes any
blanks or tabs, the entire label must be enclosed in quotes. For example, suppose
there are two links, the Tucker and Levine observed-score methods are used for
the first link, and the Tucker and Levine true-score method are used for the
second link. Then the first record for the first link might be

6If rounded scale scores are entered in the input files, certain ESUM output will be trivial,
but not wrong per se.

7Strictly speaking the records do not have to be ordered low to high or high to low, but
failure to do so can increase the likelihood of inadvertent input errors.

5



Brennan and Chien ESUM Manual

Raw Y-1 Freq Rel-freq Tucker L-obs

and first record for the second link might be

Raw Y-2 Freq Rel-freq Tucker L-true

Alternatively, the first record for the first link might be

Raw Y-1 Freq Rel-freq Tucker "L obs"

and first record for the second link might be

Raw Y-2 Freq Rel-freq Tucker "L true"

The names of the old-form scale scores (e.g., Y-1 and Y-2 for the above example)
should be different unless the links are associated with the same old form.

For each link, starting in column 5, Records 2–(n+ 1) provide the old-form
equivalents of each of the new-form raw scores in column 1. These equivalents—
as well as the scale scores for the old form in column 2 and especially the relative
frequencies in column 4—should be provided with considerable accuracy. The
authors generally use 10 decimal digits of accuracy. In most cases, a high
degree of accuracy is necessary if moments reported by ESUM are to match
those reported by the computer program used to compute the equivalents in
the first place.

The authors typically use Equating Recipes (Brennan, Wang, Kim, & Seol,
2009) to get equated scores for various methods. The addition of a relatively
simple module of code can be used to create the input files for ESUM with
equated scores provided to any desired degree of accuracy. When 10 decimal
digits are used in the input files for ESUM, experience suggests that the ESUM
moments will match those reported by Equating Recipes to at least five decimal
digits.

4 ESUM Toolbar

The ESUM toolbar is the operation center of ESUM, which uses ESUM’s VBA
functions for analyzing equating results. Five menu items, which are either
pop-up menus or commands, are found on the ESUM toolbar and are outlined
below. The menu items and associated commands are:

1. ESUM which give the ESUM Welcome Window discussed in Section 2

2. File

• New

• Open

• Input Window

• Save

• Exit

6
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3. Run Analysis

4. Summary

5. Help

• Manual

• About

4.1 File

The File menu includes five commands: New, Open, Input Window, Save and
Exit.

4.1.1 New

The New command will clear each existing worksheet in the ESUM workbook
without a prompt so that the user can start a new analysis. This command has
the same functionality as the New command in the ESUM.xlsWelcome Window.

4.1.2 Open

The Open command loads worksheet(s) from a previous run of ESUM. The
name of the workbook containing the worksheet(s) can be obtained through the
file browser. The loaded worksheet(s) include at least an Input Worksheet; ad-
ditional worksheets may be present that contain analyses for the k links (called
Link Worksheets in this manual) and summary analyses (called Summary Work-
sheets in this manual). The Open command will delete all the existing work-
sheets in ESUM before loading another workbook. The Open command in the
File menu has the same functionality as the Open command in the ESUM.xls

Welcome Window. It is strongly advised that the user click New before clicking
Open.

4.1.3 Input Window

The Input Window of ESUM provides an interface for inputting information
about links. There are three ways to input information.

1. Type the necessary information in the spaces. This is the usual way to
input linking information.

2. Load the linking information for the example that comes with ESUM (click
Load Example at the bottom of the Input Window). This is a good way
to learn quickly about what ESUM does.

3. Linking information can be loaded using the Input Worksheet of ESUM by
clicking Load Input at the bottom of the Input Window. Almost always,
this way of inputting information would be employed only when the user

7
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wants to change a piece of input in the Input Worksheet. (See discussion
at end of this section.)

The blank spaces of the Input Window should contain the following infor-
mation:

• Title: any alphanumeric text to identify this analysis

• Scores

– Lowest raw score (can be negative)

– Highest raw score

– Rounding digit for scale scores: specify the number of integer digits
to which the user wants the program to round numbers for scale
scores. For example, if the rounding digit is 0, then scale scores are
rounded to the nearest integer and if the rounding digit is 1, then
scale scores are rounded one digit to the left of the decimal point.
Note that both unrounded and rounded output are always provided.

• Links. The number of links (maximum is 4) must be provided at the top
of the Links rectangle. At the bottom of the rectangle there is a button
labeled Add a Link. When this button is clicked, a Link Information dialog
box appears that permits the user to enter the following information.

– Name. In the textbox, provide an alphanumeric name for each link,
which is printed at the top of the worksheet associated with the link.

– File. In the textbox, provide the name of the input file for each link
(see Section 3). It is assumed that the file is in the folder containing
ESUM.xls; if not, the full pathname must be provided. Alternatively,
a little box containing “. . . ” appears to the left of the textbox.
Clicking on “. . . ” brings up a file browser that can be used to select
the filename.

– Number of Methods. Provide the number of equating methods used
for each link.

– Plot difference scores relative to. Initially, a radio button indicates
that difference scores will be provided relative to old-form scale scores.
Alternatively, the user can click the Method radio button and indi-
cate the sequential number of the method to be used for comparison
purposes. For example, suppose that the input file for a particular
link has two methods labeled Tucker and Levine. If the user types
1 in the box after Method then the difference scores computed and
plotted are for Tucker minus Levine. At this point the sequential
method number, as opposed to a method name, must be provided
because the file containing the method names for the link has not yet
been read.

– Notes. Notes for each link may be provided.

8
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When all the information has been provided in the Link Information win-
dow, click Add Link which will update the information in the Input Win-
dow. The same process can be used to add more links.

To edit or delete a particular link, double-click on the name of that link in
the Input Window. A pop-up window with the information for the chosen link
appears. The user can edit the link through the pop-up window and then click
the Update button to save the editing. Or, the user can click the Delete button
to delete the link.

After all the necessary link information is given, click the OK button in the
Input Window. Doing so causes four actions to occur. First, ESUM checks
whether there are worksheets created from a previous run; if so, the user will be
prompted to save them. Second, all the worksheets, except the Input Worksheet,
are deleted, and the content in the Input Worksheet is cleared. Third, the linking
information provided in the Input Window is listed in the Input Worksheet.
Fourth, ESUM closes the Input Window.

As noted at the beginning of this section, linking information can be loaded
using the Input Worksheet of ESUM by clicking Load Input at the bottom of
the Input Window. Almost always, this way of inputting information would
be employed only when the user wants to change a piece of input in the Input
Worksheet. The process for doing so is as follows:

• make whatever changes are desired in the Input Worksheet;

• click Input Window in the File menu of the ESUM toolbar;

• click the Load Input button at the bottom of the Input Window;

• click the OK button at the bottom of the Input Window;

An easier way to alter most information is to use the edit/delete capability
discussed above.

4.1.4 Save

The Save command in the File menu causes all the current worksheets in ESUM
(which may include the Input Worksheet, the Linking Worksheets, and the
Summary Worksheets) to be saved in an Excel workbook. However, the ESUM
macros will not be saved if the name of the workbook is anything other than
ESUM.xls. That is, the ESUM macros have been restricted to work only for
a workbook named ESUM.xls. No ESUM workbook should be saved with any
extension other than .xls. See Section 4.1.2 for a discussion of how to open
a workbook with a name other than ESUM.xls. It is particularly important
to note that the Excel Save command should not be used to save an ESUM
Workbook.

9
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4.1.5 Exit

Exit brings up a dialog box with Yes, No, and Cancel. These buttons have the
functionality indicated next.

• Yes saves work in ESUM.xls, closes the ESUM toolbar, and closes
ESUM.xls. In this case, when ESUM.xls is launched, the user can click
Continue in the Welcome Window to continue work.

• No does not save work in ESUM.xls, closes the ESUM toolbar, and closes
ESUM.xls.

• Cancel removes the dialog box and allows the user to continue using the
current workbook.

4.2 Run Analysis

Based on the information provided in the Input Worksheet, an analysis of equat-
ing results for each link is performed by clicking the Run Analysis command
on the ESUM toolbar. Since the analysis is based on the Input Worksheet,
any change to a cell value of the Input Worksheet will take effect for a subse-
quent analysis, but will not affect the previous analysis. The changed value is
highlighted in blue.

For each link, data in the input file is loaded into a new worksheet, which is
referred to as a Link Worksheet in ESUM. The link name is used as the name
of the new worksheet. ESUM computes the rounded conversion tables, scale-
scores differences for both unrounded and rounded equivalents, and moments of
distributions. Also, ESUM generates four plots: the Raw-to-Scale Score Con-
versions (Unrounded) Plot; the Scale Score Differences (Unrounded) Plot; the
Raw-to-Scale Score Conversions (Rounded) Plot; and the Scale Score Differ-
ences (Rounded) Plot. These four plots are located at the bottom of the Link
Worksheet.

In the sections containing the rounded conversion tables and the rounded
scale score differences, all non-modal cell values across columns are highlighted
in red; if there is more than one mode, ESUM will highlight all values in red.

Any change made by the user to a cell value in a Link Worksheet is high-
lighted in blue.8 ESUM automatically updates any cells in that worksheet that
are linked to a changed cell, as well as any plots in that worksheet that use data
in the changed cell. If an entry is changed in a Link Worksheet, such a change
does not affect any previously created Summary Worksheets (discussed next).

4.3 Summary

After Run Analysis has been used to generate the Link Worksheets, across-links
equating results can be created and put into a Summary Worksheet, which is

8If such changes are made, they are almost always associated with scores at the extreme
of the score scale to keep the score scale within some predetermined boundaries. It is more
common to make such changes in the Summary Worksheets, rather than the Link Worksheets.
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named “Summary” followed by a serial number starting with 1. Clicking on the
Summary button on the ESUM toolbar causes a pop-up window to appear that
permits the user to select:

• the link used for comparison purposes—specifically, the old-form scale
scores (designated Y in the Summary Worksheet) for the selected link are
used for comparison purposes;

• one method for each link; and

• a weight for each link.

Note that weights must be between 0 and 1 (inclusive) and they must NOT
begin with a decimal point. So, if the desired weights are one-half and one-half,
0.5 should be used for each of them. If a weight is a repeating decimal (e.g.,
one-sixth), it is suggested that the weight be provided with at least ten decimal
digits (e.g., 0.1666666666).

ESUM first computes the new-form unrounded conversion table over links,
which is the weighted average of the scale-score equivalents for the chosen meth-
ods for each link. Then ESUM computes the new-form rounded conversion table,
as well as various difference scores, moments, and plots for both unrounded and
rounded scale-score equivalents. For the rounded equivalents and the rounded
scale score differences, all non-modal cell values across rows are highlighted in
red; if there is more than one mode, ESUM will highlight all values in red.

Any change to a cell value in the summary is highlighted in blue. ESUM
automatically updates any cells that are linked to a changed cell as well as any
plots in the worksheet that use data in the changed cell. This is an especially
useful feature when reported scale scores have a priori fixed lower and upper
limits.

4.4 Help

Help provides two kinds of help for ESUM through a pop-up list that includes
Manual and About.

4.4.1 Manual

A manual in PDF format is provided. If the user does not have a PDF reader,
one can be downloaded from http://www.adobe.com/products/acrobat. The
manual must be located in the same folder as ESUM.

4.4.2 About

About displays the contact information for ESUM.

11
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5 Worksheets

ESUM generates three types of worksheets that are called (1) the Input Work-
sheet, (2) Linking Worksheets, and (3) Summary Worksheets. These are de-
scribed below.

5.1 Input Worksheet

The Input Worksheet is generated, and the cells are populated, based on the
information provided by the user in the Input Window. The Input Worksheet
provides basic information used to generate the Linking Worksheets and Sum-
mary Worksheets.

Strictly speaking, the Input Window does not have to be used to populate
the Input Worksheet; the user could simply enter the information directly in
the Input Worksheet. This is not advised, however, since it is easy to make
errors inputting data directly into the Input Worksheet. On the other hand, it
is sometimes convenient to alter some information (e.g., change the name of a
link) in the Input Worksheet directly and then redo the analyses.

5.2 Linking Worksheets

Clicking Run Analysis generates a Linking Worksheet for each link. Cell A1
contains the title followed by the date and time in parentheses; cell A2 contains
“Results for Link link-name”; and cell A3 contains the user note for the link,
if any. The remainder of the worksheet consists of four parts:

• Top left: numerical results for unrounded scale scores

• Top right: numerical results for rounded scale scores

• Bottom left: graphical results for unrounded scale scores

• Bottom right: graphical results for rounded scale scores

5.2.1 Numerical Results

The basic numerical results (rounded and unrounded) are: (1) scale scores and
scale-score equivalents for the various equating methods; and (2) the first four
moments for scale scores and scale-score equivalents. For each link, the numer-
ical results (except the moments) in the first 4 +mj columns are read directly
from the input file for the j-th link. For each of these columns, the column
headings are those specified in the first record of the input file. As indicated in
section 3, these columns are:

1. raw score (designated Raw_Score below)

2. scale score for old form (designated Old_Form_Scale_Score below)

3. frequency for new form

12
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4. relative frequency for new form

5. scale score for first method (designated M1 below)

6. scale score for second method (designated M2 below)

· · ·

4 +mj . scale score of mj-th method (designated Mj below)

If the user has specified that differences should be plotted relative to the
old-form scale scores (see page 8), the subsequent mj columns are

5 +mj . Old_Form_Scale_Score - M1

6 +mj . Old_Form_Scale_Score - M2

· · ·

4 + 2mj . Old_Form_Scale_Score - Mj

If the user has specified that differences should be plotted relative to scale scores
for particular method (see page 8), there will be mj − 1 subsequent columns.

In the section containing the rounded equivalents and the rounded scale-
score differences, all non-modal cell values across columns are highlighted in
red; if there is more than one mode, ESUM will highlight all values in red.

Below each column for a scale score or scale-score difference, the first four
moments are provided. Note that these moments are based on the relative
frequencies in the fourth column.

Any numerical entry in the columns (other than the moments) can be
changed by the user. If so, the changed value is colored blue and all results
(numerical and graphical) based on the changed value are altered appropriately.
The most likely use of this feature of ESUM is to alter scale-score equivalents
that are outside some predefined range. Note the following:

• If a value is altered and then Run Analysis is clicked, the altered values
are not retained, Linking Worksheets are cleared, Summary Worksheets
are cleared, and new Linking Worksheets are created based on the Input
Worksheet.

• If a change is made in a Linking Worksheet, the change does not affect
any existing or subsequently-created Summary Worksheets. That is, each
Summary Worksheet must be altered directly.

5.2.2 Graphical Results

Below the moments in the Linking Worksheets are graphical results (rounded
and unrounded). The first graph plots the scale-score equivalents in columns
5–(4+mj) against raw scores. The second graph plots the scale-score differences
against raw scores.
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5.3 Summary Worksheets

Clicking Summary generates a Summary Worksheet across all links. A Sum-
mary Worksheet is based on a user-defined weighed average of the user-selected
method for each link. There can be as many Summary Worksheets as desired.
Cell A1 contains the title followed by the date and time in parentheses. Cell A2
contains “Summary over Links (Comparison: Y = old-form scale scores for link:
link-name”. (For the specified link, this is the second column in the Linking
Worksheet.) The remainder of the worksheet consists of four parts:

• Top left: numerical results for unrounded scale scores

• Top right: numerical results for rounded scale scores

• Bottom left: graphical results for unrounded scale scores

• Bottom right: graphical results for rounded scale scores

5.3.1 Numerical Results

For the first 1 + k columns, the numerical results are:

1. raw score

2. old-form scale score for selected method for link 1

3. old-form scale score for selected method for link 2

· · ·

1 + k. old-form scale score for selected method for link k

One of these columns begins with the designator Y =, as specified by the user
in the dialog box entitled ”Create a Summary over Links” that appears when
the user clicks Summary (see Section 4.3). The Y-column old-form scale scores
are used as a basis for comparison in the last few columns in the Summary
Worksheet.

The next 2 + k columns are:

2 + k. frequency

3 + k. relative frequency

4 + k. new-form scale score for selected method for link 1

5 + k. new-form scale score for selected method for link 2

· · ·

3 + 2k. new-form scale score for selected method for link k
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Usually, for the k links the frequencies and relative frequencies are the same. If
they are different, for a Summary Worksheet ESUM uses the frequencies and
relative frequencies for link k.

The remaining columns are:

4 + 2k. weighted average of new-form scale scores for selected methods;
this is the principal result in a Summary Worksheet

5 + 2k. difference between Y and weighted average

6 + 2k. difference between Y and scale score for link 1 (i.e., column 4+ k)

7 + 2k. difference between Y and scale score for link 2 (i.e., column 5+ k)

· · ·

5+3k. difference between Y and scale score for link k (i.e., column 3+2k)

The next set of columns contain the “rounded scores” version of those dis-
cussed above. For the rounded equivalents and the rounded scale-score differ-
ences, all non-modal cell values across columns are highlighted in red; if there
is more than one mode, ESUM highlights all values in red.

Below each column for a scale score or scale-score difference, the first four
moments are provided. These moments are based on the relative frequencies in
column 3 + k.

Any numerical entry in the columns (other than the moments) can be
changed by the user. If so, the changed value is colored blue and all results
(numerical and graphical) based on the changed value are altered appropriately.
The most likely use of this feature of ESUM is to alter scale-score equivalents
that are outside some predetermined range.

5.3.2 Graphical Results

Below the moments in a Summary Worksheet are graphical results (rounded
and unrounded). The first graph plots column 5 + 2k (difference between Y

and weighted average) against raw scores. The second graph plots columns
(5 + 2k)–(5 + 3k) (scale-score differences for each link) against raw scores.

6 Notes

No suggestion is made here that the output from ESUM is necessarily optimal
or sufficient for making all decisions about choice of equating methods in an
actual testing program. Almost all testing programs have unique features that
warrant paying attention to additional, program-specific information to make
equating decisions.
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6.1 Enabling Macros and Security

There are four levels of Microsoft Excel security: Very High, High, Medium and
Low. With Low security, macros run automatically, but Low security may allow
unsafe macros. Medium security is recommended for running ESUM. With High
security, only trusted Excel macros are allowed. A macro is trusted when it has
been digitally signed and the user chooses to trust the source. With Very High
security, only macros installed in trusted locations are allowed to run. All other
signed and unsigned macros are disabled.

6.1.1 Excel 2003

The Microsoft Excel macro security setting can be found under Tools→Macros→
Security. With Medium security, a pop-up window appears each time a work-
book is opened, and the user is asked to “Enable” or “Disables” Excel macros.

6.1.2 Excel 2007

In Excel 2007, the steps for setting the security level are as follows:

1. Click the large button (called the Office Button) on the left of the ribbon

2. Click “Excel Options” at bottom of the list

3. Click Trust Center→Trust Center Settings→Macro Settings and select the
box labeled “Disable all macros with notification.” In the same window
make sure the box labeled “Trust access to VBA project object module”
is checked.

4. Click “OK” to close the “Trust Center” window.

5. Click “OK” to close the “Excel Options” window.

Each time ESUM is run a dialog box will ask you to Enable Macros.
Rather than selecting the “Disable all macros with notification” box in Step

3 you can select “Enable all macros,” but this is not generally recommended.
If “Enable all macros” is selected, no dialog box will appear that asks you to
enable macros when ESUM is run.

6.1.3 Excel 2010

In Excel 2010, the steps for setting the security level are as follows:

1. Click File→Options→Trust Center→Trust Center Settings→Macro Set-
tings and select the box labeled “Disable all macros with notification.” In
the same window make sure the box labeled “Trust access to VBA project
object module” is checked.

2. Click “OK” to close the “Trust Center” window.
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3. Click “OK” to close the “Excel Options” window.

When ESUM is run, click the button labeled “Enable Content” (which enables
macros), if the button appears.

Rather than selecting the “Disable all macros with notification” box in Step
1 you can select “Enable all macros,” but this is not generally recommended.
If “Enable all macros” is selected, it is not necessary to click “Enable Content”
each time ESUM is run.

6.2 Add-Ins

When ESUM.xls is opened in Excel 2003, the floating toolbar described in Sec-
tion 4 appears automatically. For Excel 2007 and 2010, however, obtaining the
functionally equivalent Add-Ins is more complicated.

6.2.1 Excel 2007

Rather than double clicking on ESUM.xls, open Excel 2007 first and then open
ESUM.xls using the Open command in the Office Button on the left side of
the ribbon. (The Workbook window will be labeled “ESUM [Compatibility
Mode].”) Just below the ribbon there will be a security warning saying “Macros
have been disabled.” Click the Options... button next to the warning and select
“Enable the content.” The ESUM Welcome Window will appear. When one
of the buttons in the ESUM Welcome Window is clicked, an Add-Ins tab will
be added to the ribbon. Clicking the Add-Ins tab will put the ESUM Add-Ins
(i.e., toolbar) just below the ribbon. This toolbar is not a floating toolbar, as
it is in Excel 2003. At any time, if the ESUM Add-Ins disappear, simple click
the Add-Ins tab.

6.2.2 Excel 2010

If the Add-Ins tabs is not in the ribbon, click File→Options→Customize Rib-
bon. To the right, under “Main Tabs”, check “Add-Ins.” Then click “OK” to
exit. When ESUM is opened, the Workbook window will be labeled “ESUM
[Compatibility Mode]” and the ESUM Welcome Window will appear. When
New or Continue is clicked, an Add-Ins tab will be added to the Workbook
window. Clicking the Add-Ins tab will put the ESUM Add-Ins (i.e., toolbar)
just below the ribbon. This is not a floating toolbar, as it is in Excel 2003. At
any time, if the ESUM Add-Ins disappear, simple click the Add-Ins tab.

6.3 Modifications of ESUM

All functions in Excel can be used in ESUM, which means that Excel can be
used to modify the computed data and plots created by ESUM, as well as add
additional information and notes. The ESUM VBA code is open-source. Users
may modify it in any way desired. The rest of this section discusses how to
access the ESUM code.
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6.3.1 Excel 2003

In Excel 2003, while using the ESUM.xls workbook, choose Tools→Macro→
Visual Basic Editor. If Project Explorer is not visible, choose View→Project
Explorer. Click “+” beside Modules, and double click “Module2.” To see the
code for any form, click “+” beside “Forms,” click the form name, and click the
first box just below “Project - VBA Project.”

6.3.2 Excel 2007

In Excel 2007, the code is accessed through the Developer tab on the ribbon. if
the Developer tab is not present,

1. click the large button (called the Office Button) on the left of the ribbon,

2. click “Excel Options,”

3. select “Popular,”

4. check the box labeled “Show Developer tab in the Ribbon,”

5. click “OK” to exit the window.

To see the Visual Basic code, click the Developer tab, click the Visual Basic
icon, click “+” beside Modules, and double click “Module2.” To see the code
for any form, click “+” beside “Forms”, click the form name, and click the first
box just below “Project - VBA Project.”

6.3.3 Excel 2010

In Excel 2010, the code is accessed using the Developer tab on the ribbon. If
the Developer tab is not in the ribbon, click File→Options→Customize Ribbon.
To the right, under “Main Tabs”, check “Developer.” Then click “OK” to exit.

To see the Visual Basic code, click the Developer tab, click the Visual Basic
icon, click “+” beside Modules, and double click “Module2.” To see the code
for any form, click “+” beside “Forms,” click the form name, and click the first
box just below “Project - VBA Project.”

7 Open Source License

The ESUMVBAmacros code is distributed under the GNU Lesser General Pub-
lic License, version 3 (LGPLv3), June 29, 2007, which grants certain permissions
beyond those in the GNU General Public License, version 3 (GPLv3), June 29,
2007. A copy of these licenses is contained in the ReadMe file distributed with
ESUM (see, also, http://fsf.org or http://www.gnu.org/licenses). The
following discussion provides a shorter, simplified version of prominent license
conditions. This summary should not be interpreted as limiting, expanding, or
in any way altering the license conditions in LGPLv3.
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This license applies to the VBA macros code and comes with any rights that
the authors have in it (other than trademarks). You agree to the the terms of
this license by copying, distributing, or making a derivative work of the software.
You get the royalty free right to:

• use the software for any purpose;

• make derivative works of it (this is called a “Derived Work”); and

• copy and distribute it and any Derived Work.

If you distribute the software or a Derived Work, you must give back to the
community by:

• prominently noting the date of any changes you make;

• leaving other people’s copyright notices, warranty disclaimers, and license
terms in place;

• providing the source code in a form that is easy to get and modify;

• licensing it to everyone under the LGPLv3 license, without adding further
restrictions to the rights provided; and

• conspicuously announcing that it is available under that license.

Furthermore,

• you get NO WARRANTIES—none of any kind; and

• if the software damages you in any way, you may only recover direct
damages up to the amount you paid for it (that is zero if you did not pay
anything). You may not recover any other damages, including those called
“consequential damages.” (The state or country where you live may not
allow you to limit your liability in this way, so this may not apply to you).

This license continues perpetually, except that your license rights end auto-
matically if you do not abide by the “give back to the community” terms (your
licensees get to keep their rights if they abide by the terms of this license).

Note that LGPLv3 permits use of the code in proprietary programs, whereas
GPLv3 does not.
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